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5Organizacija podataka 
 

Organizacija podataka je od bitne važnosti u informatičkom društvu. Dostupnost 
podataka za relativno kratko vreme doprinosi produktivnosti što i jeste krajnji cilj 
informacionih tehnologija. Medjutim, pre nego što se pozabavimo principima organizacije 
podataka, objasnićemo osnovne principe identifikacije uredjaja pod operativnim sistemom 
Windows i to na primeru HDD-a kao osnovnog uredjaja spoljašnje memorije. Da bi 
operativni sistem mogao da ostvari komunikaciju sa uredjajima spoljne memorije (pre 
svega HDD) svakom uredjaju dodeljuje jedinstveni identifikator ili logičko ime. Identifikator 
ili logičko ime uredjaja spoljašnje memorije sastoji se iz slova abecede (a, b, c ...) i 
dvotačke (":"). Logička imena koja počinju slovima a i b (npr a: i b:) rezervisana su za 
disketne jedinice (FDD) ili interni ZIP drive, a sva ostala (npr c:, d:, ... , z:) se redom 
dodeljuju HDD-ovima ili logičkim particijama na diskovima, CD jedinicama, DVD 
jedinicama, eksternim ZIP drivovima, i drugim uredjejima spoljne memorije ili periferije. 

Broj internih uredjaja spoljne memorije zavisi od broja kontrolera ovih uredjaja na 
matičnoj ploči. Većina matičnih ploča podržava 2 + 4 interna uredjaja spoljne memorije i to 
1 ili 2 disketne jedinice ili internih ZIP drive-ova i 1 do 4 HDD-ova ili CD Drive-ova, 
odnosno njihovih kombinacija (1HDD+1CDD, 2HDD+1CDD,1HDD+1CDD+1CDRW,...). 
Broj eksternih uredjaja spoljne memorije nisu predmet ovog razmatranja.  

Medjutim, na svakom fizičkom HDD-u moguće je formirati i nekoliko logičkih 
particija. Particioniranje HDD podrazumeva raspodelu memorijskog ukupnog kapaciteta 
HDD na više nezavisnih memorijskih kapaciteta (slika 1).  
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Slika 1. Primer raspodele kapciteta HDD 

 

Na slici 1 prikazana je raspodela memorijskog kapaciteta jednog HDD-a. 50% 
ukupnog kapaciteta dodeljena je primarnoj particiji koja će dobiti logičko ime C:, a ostatak 
kapaciteta raspodeljen je na dve logičke particije koje će dobiti ime D: i E: prema 
redosledu formiranja. Dodela logičkih imena ostalim uredjajima spolajšnje memorije 
nastaviće se redosledom F:, G:, ... Medjutim ako u računarskom sistemu postoji više HDD-
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ova pri dodeli logičkih imena prednost imaju primarne particije ovih uredjaja pa potom sve 
ostale logičke particije HDD, a za njima i svi ostali uredjaji spolajšnje memorije.     

Sada kada smo objasnili principe identifikacije uredjaja spoljašnje memorije, 
možemo se pozabaviti organizacijom podataka. Kao primer uzećemo školsku arhivu 
učenika u nekoj srednjoj školi.  

 

 

 

 

 

 

 

 

 

Slika 2. Primer organizacije školske arhive učenika  

Način organizacije podataka prikazan na slici 2 daje mogućnost najbržeg i 
najednostavnijeg pronalaženja traženog (potrebnog) dokumenta u školskoj arhivi sa 
minimalnim početnim informacijama. Na primer: Jovana traži svoj izvod iz matične knjige 
rodjenih od školskog službenika. Da bi školski službenik pronašao traženi dokument 
potrebne su mu samo tri informacije i to: Jovanin razred, Jovanino odeljenje i njeno puno 
ime i prezime i traženi izvod je pronadjen za relativno kratko vreme. Da nije ovakva 
organizacija traženje izvoda bi moglo da potraje veoma dugo.  

Ovakav način organizacije podataka je poznat kao organizacija u obliku stabla gde 
je polazište (koren stabla) kancelarija arhive (jer u jednoj kancelariji mogu postojati više 
ormara arhive, npr. arhiva radnika ...) a sve ostalo su grane tog stabla.  
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Sadržaj pojedinačnih fascikli (izvod, molba, lekarsko uverenje ...) obično 
nazivamo, univerzalnim imenom, dokumenti. Dokumenti su obično skupovi podataka koje 
vezuje neka zajednička osobina (npr. kod izvoda to je ime i prezime rodjenog, ...). 
Analogno tome skupovi podataka na računaru takodje se nazivaju dokumentima, odnosno  
datotekama (kod ranijih operativnih sistema) ili File-ovima (kod savremenih operativnih 
sistema). Kako mi radimo sa Windows operativnim sistemom koristićemo naziv File. 
Raspoznavanje File-ova ostvaruje se na osnovu njihovih imena. Ime File-a sastoji se i 
osnovnog imena (do 255 znakova bez upotrebe znakova \ / : * ? < > .) i dodatka 
(ekstenzije) od 3 slova odvojenog "tačkom" (primer: ovojefile.txt). U zavisnosti od 
ekstenzije moguće je prepoznati o kom tipu File-a se radi. Razlikujemo nekoliko 
univerzalnih ekstenzija koje se najčešće sreću prilikom rada na računaru i to: 

.exe, .com - označavaju da se radi o programima 

.txt, .rtf, .doc  - označavaju da se radi o tekstualnim file-ovima 

.bmp, .gif, .jpg  - označavaju da se radi o slikama 

.dll, .vxd, .sys  - označavaju da se radi o sistemskim file-ovima   

Svi fajlovi na računaru raspodeljuju se prema svojim zajedničkim karakteristikama 
po Folder-ima, što bi bilo analogno faskiklama u kojima se nalaze dokumenti. Kao i kod 
školske arhive fascikle se mogu nalaziti u kutijama što bi analogno bilo da se i Folder(-i) 
mogu nalaziti u drugim Folder-ima. Moglo bi se reći da su Folder-i ustvari skupovi različitih 
File-ova i/ili drugih Folder-a. Svaki uredjaj spoljne memorije (na primer: HDD i njegove 
logičke particije) imaju po jedan osnovni Folder. Taj folder se, anlogno organizaciji 
podataka u obliku stabla, naziva koreni (ROOT) folder. Kod ranijih verzija operativnih 
sistema folder se nazivao direktorijum. Svaki folder ima svoje ime koje za razliku od File-
ova nema ekstenziju. Put do sadržaja nekog foldera na disku naziva se putanja (eng. 
path).     

 
Windows Explorer 

Windows Explorer je osnovni program (File menager) za organizaciju podataka i 
manipulaciju sa njima. Zato će mo se upoznati sa osnovnim principima rada sa ovim 
programom.  Startovanje ovog programa možemo ostvariti na sledeći način: 

 1. Desni klik na ikonicu (npr. My Computer)   

           
2. Klik na opciju Explore u padajućem meniu  
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prikaz putanje  
selektovanog 

foldera 

prikaz sadržaja 
selektovanog 

foldera 

prikaz foldera 
u obliku stabla  

(Tree view) 

Slika 3. Izgled prozora Windows Explorer-a 

Na slici 3 prikazan je osnovni izgled prozora Windows Explorera. U polju na levoj 
strani ovaj program prikazuje sadržaj računara i to u osnovi samo sistemske ikonice koje 
se nalaze na Desktop-u (My Computer, My Network Places, Recycle bin ...) ili u 
proširenom obliku sve foldere koji se nalaze na selektovanom uredjaju spoljašnje 
memorije. U polju na desnoj strani ovaj program prikazuje kompletan sadržaj selektovanog 
uredjaja spoljne memorije ili nekog selektovanog foldera. Folderi su predstavljeni ikonicom 
koja podseća na zatvorenu fasciklu, a File-ovi su predstavljeni ikonicom čija sličica asocira 
na tip file-a i imenom sa/bez ekstenzijom.  

Selektovanje foldera obavlja se klikom na ikonicu foldera u polju na levoj strani ili 
dvostrukim klikom na ikonicu u polju na desnoj strani prozora Windows Explorera.  

 

prikaz  
putanje do 

selektovanog 
foldera 

Slika 4. Izgled prozora sa selektovanim folderom 

Ukoliko se selektuje neki folder njegova ikonica se pretvara u ikonicu koja asocira 
na otvorenu fasciklu (otvoren folder), u polju na desnoj strani Windows Explorer-a dobija 
se sadržaj otvorenog folder-a, a u polju iznad daje se prikaz imena selektovanog foldera.  
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Kreiranje novog foldera 

Kreiranje novog foldera obavlja se kroz nekoliko koraka i to: 

1.  Selektovanje foldera ili uredjaja spoljne memorije (npr. Local Disk (C:)) 

   Slika 5 

2. Klik na opciju File ► New ► Folder u Windows Exploreru  

       Slika 6 

    Slika 7 

3. Definisanje imena novokreiranog foldera u polju na desnoj strani                 
Windows Explorer-a (npr. VEZBA) 

  Slika 8 

4. Klik u "PRAZNO" ili pritisak na taster "ENTER" 

  Slika 9 
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Promena imena (preimenovanje) foldera  

Preimenovanje foldera obavlja se kroz nekoliko koraka i to: 

1.  Selektovanje foldera u polju na levoj strani kome želimo da promenimo ime  

  Slika 10 

2. Klik na opciju File ► Rename u Windows Exploreru  

  Slika 11 

  Slika 12 

3. Definisanje novog imena foldera u polju na levoj strani Windows Explorer-a 

  Slika 13 

4. Klik u "PRAZNO" ili pritisak na taster "ENTER" 

  Slika 14 
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Uklanjanje (brisanje) foldera  

Foldera se može izbrisati onda kada nam njegov sadržaj nije potreban. Brisanje  
foldera obavlja se kroz nekoliko koraka i to: 

1.  Selektovanje foldera koji želimo da obrišemo  

  Slika 15 

2. Klik na opciju File ► Delete u Windows Exploreru  

  Slika 16 

3. Potvrda brisanja klikom na dugme "Yes" na prozoru za potvrdu 

 Slika 17 

NAPOMENA: Potvrdite brisanje klikom na YES tek nakon sto proverite da je pod 
znacima navoda naznačeno ime foldera koji želite da obrišete 

 

Kopiranje file-ova i folder-a 

Kopiranje file-ova i folder-a podrazumeva proces pravljenja njihovih kopija u 
nekom drugom folderu ili na uredjaju spoljne memorije ili njihovo premeštanje iz jednog u 
drugi folder. Stoga možemo razlikovati metodu Copy - Paste i metodu Cut - Paste.    

Obe metode koriste deo memorije koji se zove Clipboard za privremeno smeštanje  
kopija selektovanih file-ova. Princip ovih metoda prikazan je na sledećoj slici. 

PASTE 

 
Sadržaj foldera 1 

 
Folder  2 

 
Sadržaj foldera 1 

 

COPY 

DELETE CUT 

Folder  1

 
Clipboard 

PASTE 

 
Sadržaj foldera 1 

 
Folder  2

COPY 

 
Sadržaj foldera 1 

 
Folder  1

 
Clipboard  

 

 

 

 

Slika 18. Metode Copy-Paste i Cut-Paste 
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KOPIRANJE FILE-OVA COPY - PASTE 

1. Selektovanje file-a (folder-a) koji želimo da iskopiramo  

  Slika 19 

2. Klik na opciju Edit ► Copy u Windows Exploreru  

  Slika 20 

3. Selektovanje folder-a u kome smeštamo kopiju  

  Slika 21 

4. Klik na opciju Edit ► Paste u Windows Exploreru 

  Slika 22 

  Slika 23 
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KOPIRANJE FILE-OVA CUT - PASTE 

1. Selektovanje file-a (folder-a) koji želimo da iskopiramo  

  Slika 24   

2. Klik na opciju Edit ► Cut u Windows Exploreru  

  Slika 25 

   Slika 26 

3. Selektovanje folder-a u kome smeštamo kopiju  

  Slika 27 

4. Klik na opciju Edit ► Paste u Windows Exploreru 

  Slika 28 
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Metodom Copy - Paste kopiramo sadržaj jednog foldera (npr. Folder 1) u drugi 
folder (npr. Folder 2), pri čemu sadržaj prvog foldera (Folder-a 1) ostaje nepromenjen.    

Metoda Cut - Paste će ukloniti selektovani file nakon završenog procesa kopiranja. 
Poznata je još i pod imenom Move (pomeri), a istu operaciju je moguće uraditi i sa 
metodom Copy - Paste uz korišćenje opcije Delete iz File menia Windows Explorer-a što 
povećava ukupan broj koraka.  

Ove dve metode su neophodne prilikom kopiranja file-ova na neki od prenosivih 
uredjaja spoljne memorije kao bi se isti mogli prenositi po potrebi.         

 

Selektovanje sadržaja foldera 

Selektovanje sadržaja selektovanog foldera obavlja se u polju na desnoj strani 
prozora Windows Explorer-a. Pojedinačno selektovanje file-ova obavlja se klikom na 
ikonicu file-a.  

Kombinacijom tastera "SHIFT" na tastaturi (oznaka = ) i klika moguće je 
selektovati početni i poslednji file u nizu i sve file-ove izmedju njih.  

 
Slika 29. Selektovanje kombinacijom Shift + Klik 

Kombinacijom tastera "CTRL" i klika moguće je selektovati proizvoljno file-ove. 
Takodje, moguće je koristiti metodu prevlačenja za selektovanje grupe file-ova. 

 
Slika 30. Selektovanje kombinacijom Ctrl + Klik 

 Za selektovanje kompletnog sadržaja selektovanog foldera koristimo opciju:                 
Edit ► Select All  u Windows Exploreru    

 
Slika 31. Selektovanje kompletnog sadržaja foldera 
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Pretraživanje računara 

Ukoliko ne znamo tačno gde nam se nalazi file koji nam je potreban možemo 
koristiti opciju za pretraživanje računara. Pretraživanje računara ostvaruje se na sledeći 
način: 

1. Selektujemo folder koji želimo da pretražimo (npr: Local Disk (C:)) 

  Slika 32 

2. Klik na dugme Search ( ) na Toolbar-u 

3. Izbor tipa file-a koji pretražujemo (Pictures ... , Documants ... , ...) 

  Slika 33 

4. Definisanje parametra pretrage  

  Slika 34 

5. Klik na dugme Search ( ) za pokretanje pretrage  

6. Prikaz rezultata pretrage 

  Slika 35 
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Podešavanje Windows Explorer-a 

Osnovno podešavanje Windows Explorera sastoji se u podešavanju vidljivosti            
file-ova. Klikom na: View ► Options... dobijamo mogućnost osnovnih podešavanja. 

      

tip prikaza foldera 

otvaranje foldera u istom ili 
novom prozoru 

broj klik-ova potrebnih za 
otvaranje foldera 

prikaz foldera u sistemski 
predvidjenom obliku 

Slika 36. Osnovna podešavanja 

 

prikaz svih foldera u prikazu 
kao što je tekući prikaz foldera u sistemski 

predvidjenom obliku 

skrivanje file-ova  

prikaz putanje do file-ova  
u adresnoj liniji  

Prikaz skrivenih file-ova  

skrivanje ekstenzija pri  
prikazu file-ova 

Slika 37. Podešavanja prikaza 
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